Dumma bilder

Jag vill kunna ladda upp hur himla stora bilder jag vill till min hemsida och sedan skala om dem på ett trevligt vis. Själva omskalningen vet jag hur jag ska få till, men uppladdandet av bilderna strular.

Halva bilden blir grå, så jag börjar misstänka att resten av bilden ligger bredvid den temp-fil jag petar på när bilden är uppladdad? Eller är det något helt annat problem? Typ att bilden inte alls blir helt uppladdad, men att den skulle tagits emot om den blivit det?

Jag har lagt upp ett exempel på en dåligt uppladdad bild på hemsidan om någon undrar vad jag dillar om.

Ja, och här på bloggen kan man ju minsann ladda upp hur stora bilder man vill. Hur går det till, och finns det scriptet enkelt utklippt av någon händig person? Jag blir bara trött när jag försöker hitta i wp-koden. Kanske för att den är för strukturerad och jag är van vid min egna ostrukturerade, okommenterade kod? =)

Är det som sagt någon som har en lösning på detta problem? Släng en kommentar på mig så att jag får lösa detta någon gång!

Just nu finns detta i min .htaccess-fil:

php_value post_max_size 125829120
php_value upload_max_filesize 134217728
php_value memory_limit 134217728

Jag har typ satt jättestora värden där för att jag blev så frustrerad.

EDIT 2010-07-23 : eftersom jag nu både löst problemet och tagit bort problembilden kan man inte längre se denna. Det var väl lite dumt att inte posta här på bloggen, men nu hittade jag ju istället följande lilla lustighet;

Flattr this!

3 reaktioner på ”Dumma bilder”

  1. Det är med största sannolikhet en PHP-inställning på servern snarare än en WP-inställning i sig. Hur lång tid får scriptet på sig att köras? Får du någon timeout efter 30 sekunder eller så?

  2. Det är med största sannolikhet en PHP-inställning på servern snarare än en WP-inställning i sig. Hur lång tid får scriptet på sig att köras? Får du någon timeout efter 30 sekunder eller så?

    max_execution_time eller något sådant ska den inställningen heta…

  3. Nej det tar inte alls lång tid att få upp den trasiga bilden! =) Runt 6 sekunder, och max_execution_time är ju 30 by default, så det är nog inte orsaken. Anledningen till att jag sneglar irriterat åt wp är ju för att det funkar här!

    Jag är inte alls benägen att tro att felet ligger på servern utan tror snarare att det är något man behöver göra i koden för att detta ska funka…

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *